Solution to Lab Challenge IGP (EIGRP, OSPF and RIP)

Please take into consideration that there are most of the time different ways to solve a task and some I did even not think about. I gonna show you the solutions I had in mind. If you think you got another or even better solution to a task, please feel free to comment about it or send me an e-mail.

lab_challenge_igp

EIGRP

Tasks: Configure EIGRP AS 100 between R1,R2 and R3.
Advertise the networks 116.1.2.0/24 and 116.1.3.0/24, do not use the network statement.
Configure EIGRP between R1, R4 and R5. Include all Loopback Interfaces on R1 – R4

Redistribute Connected

Task: Advertise the networks 116.1.2.0/24 and 116.1.3.0/24, do not use the network statement.

To get the networks 116.1.2.0/24 and 116.1.3.0/24 into EIGRP without using the network statement, you will have to use redistribution. A way to do that is to redistributed connected into EIGRP and since we do not want to redistribute every connected interface into EIGRP (you can use the network statement for both other networks) we’ll use a route-map which only matches on those networks:

R2
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R2-Connected
 network 99.99.2.2 0.0.0.0
 network 116.1.123.2 0.0.0.0
 no auto-summary
!
ip prefix-list R2-fa0/0 seq 5 permit 116.1.2.0/24
!
route-map R2-Connected permit 10
 match ip address prefix-list R2-fa0/0

R3
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R3-Connected
 network 99.99.3.3 0.0.0.0
 network 116.1.123.3 0.0.0.0
 no auto-summary
!
ip prefix-list R3-fa0/0 seq 5 permit 116.1.3.0/24
!
route-map R3-Connected permit 10
 match ip address prefix-list R3-fa0/0

You can also use a match interface statement instead of matching with an ip prefix-list within the route-map.

EIGRP, Frame-Relay and split-horizon

Task: Configure EIGRP AS 100 between R1,R2 and R3.

To solve this task, you either have to configure EIGRP for unicast or assure that Frame-Relay transports multicast. I’ve chosen to configure Frame-Relay to transport multicast with the broadcast statement at the end of each frame-relay map statement so I did not have to do anything special within the EIGRP configuration.
Another thing to keep in mind, EIGRP is a distance vector protocol in some parts and uses the split-horizon rule. In that environment R1 will never advertise any routing information from R2 to R3 and vice versa due to the split horizon rule. You could use Frame-Rleay sub-interfaces on R1 but then you would not only use the physical interfaces as the Frame-Relay configuration task asks for. So the only way to pass those updates is to disable split-horizon on R1’s serial interface.

R1
interface Serial1/0
 ip address 116.1.123.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 serial restart-delay 0
 frame-relay map ip 116.1.123.2 102 broadcast
 frame-relay map ip 116.1.123.3 103 broadcast
!
router eigrp 100
 network 0.0.0.0
 no auto-summary

R2
interface Serial1/0
 ip address 116.1.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 116.1.123.1 201 broadcast
 frame-relay map ip 116.1.123.3 201
!
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R2-Connected
 network 99.99.2.2 0.0.0.0
 network 116.1.123.2 0.0.0.0
 no auto-summary

R3
interface Serial1/0
 ip address 116.1.123.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 116.1.123.1 301 broadcast
 frame-relay map ip 116.1.123.2 301
!
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R3-Connected
 network 99.99.3.3 0.0.0.0
 network 116.1.123.3 0.0.0.0
 no auto-summary

Everything else within the EIGRP part is pretty straight forward, if not you can find the full configuration for every router at the end of this article.

EIGRP verification

A show ip route on R2 shows that it has all EIGRP routes in its routing table:

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     116.0.0.0/24 is subnetted, 4 subnets
C       116.1.123.0 is directly connected, Serial1/0
D EX    116.1.3.0 [170/2561024256] via 116.1.123.1, 00:24:17, Serial1/0
C       116.1.2.0 is directly connected, FastEthernet0/0
D       116.1.145.0 [90/2172416] via 116.1.123.1, 00:24:18, Serial1/0
     99.0.0.0/24 is subnetted, 5 subnets
D       99.99.1.0 [90/2297856] via 116.1.123.1, 00:24:18, Serial1/0
C       99.99.2.0 is directly connected, Loopback0
D       99.99.3.0 [90/2809856] via 116.1.123.1, 00:24:17, Serial1/0
D       99.99.4.0 [90/2300416] via 116.1.123.1, 00:24:18, Serial1/0

A side effect of the redistribute connected on R2 and R3 is that both of their interfaces are integrated as EIGRP external routes, it does not affect anything at the moment but keep that in mind for later.

OSPF

Tasks: Configure OSPF between R4,R5,R6. Do not use the neighbor statement to get the adjacencies up. Ensure that R6 is always the DR.
Configure OSPF between R6 and R7
Configure between R7 and R8
Include all Lo 0s from R5 – R7, ensure that they appear as /24 entries in the routing table.

OSPF and Frame-Relay

Task: Configure OSPF on R4,R5,R6. Do not use the neighbor statement to get the adjacencies up. Ensure that R6 is always the DR.

This task can be split in two parts:

  • get the adjacencies up without using the neighbor statement
  • Configure R6 to always be the DR on that circuit

OSPF uses the NONBROADCAST network type as default for Frame-Relay interfaces and hence you would have to configure the neighbors (at least on the hub) to get OSPF up and running. So to fulfill that requirement, you’ll have to change the network type for the interfaces. Basically the OSPF network types do not have to correlate to the L2 medium, we could configure NONBROADCAST on an Ethernet link on both sides with neighbor statements and it would still work. The network types “only” define how OSPF handles its timers (Hello, Dead and Wait), if a DR and a BDR are elected and how the updates are sent (unicast/multicast) which are all points that have to match to get a working OSPF adjacency. Its also not necessary that the network types on each router are the same, as long as their timers and DR/BDR settings match. So at the moment we could choose either the BROADCAST or the POINT-TO-MULTIPOINT network types. But since we need a DR/BDR election theres only one type left: BROADCAST, since the other one does not elect any DR/BDR.
The last part is easy, before OSPF forms its adjacencies, the Interfaces have to be configured for their DR priority (otherwise you would have to clear the OSPF process). The default is 1 for every interface, setting it to 0 (zero) on R4 and R5 will prevent them from getting elected as DR and setting the priority to 255 on R6 will assure that it will allways (well as long as we dont configure another router with 255) be the DR. During preparations for the CCIE Lab I was once told to min/max stuff like this, that’s why I set it to the maximum value possible on R6, leaving it to its default would do the same after the change to priority 0 on the other routers.

R4
interface Serial1/0
 ip address 116.1.156.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 116.1.156.5 406
 frame-relay map ip 116.1.156.6 406 broadcast
!
router ospf 1
 router-id 99.99.4.4
 log-adjacency-changes
 network 116.1.156.4 0.0.0.0 area 0

R5
interface Serial1/0
 ip address 116.1.156.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 116.1.156.4 506
 frame-relay map ip 116.1.156.6 506 broadcast
!
router ospf 1
 router-id 99.99.5.5
 log-adjacency-changes
 network 116.1.156.5 0.0.0.0 area 0

R6
interface Serial1/0
 ip address 116.1.156.6 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 255
 serial restart-delay 0
 frame-relay map ip 116.1.156.4 604 broadcast
 frame-relay map ip 116.1.156.5 605 broadcast
!
router ospf 1
 router-id 99.99.6.6
 log-adjacency-changes
 network 116.1.156.6 0.0.0.0 area 0

OSPF and Areas without a direct Backbone Area connection

Tasks:
Configure OSPF between R6 and R7
Configure between R7 and R8

OSPF between R6 and R7 is just a straight forward OSPF connection, nothing special about it. OSPF between R7 and R8 is not, as you probably already saw. OSPF areas always have to have a direct connection to the backbone area and well, area 78 doesnt have any connection to the backbone area so the rest of the network will never know about the routes from area 78 and later the ones from the RIP part until we connected area 78 to the backbone area. To connect it to the backbone area we basically got two options:

  • OSPF virtual-link
  • GRE-Tunnels

You can use both of them to get a full routing connectivty in that case, for the solution guide, I’ve taken the virtual-link path since its an OSPF tool. The virtual-link has to be configured between R6 (last router for the backbone area) and R7 (first router for area 78).

R6
interface FastEthernet0/0
 ip address 116.1.67.6 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.156.6 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 255
 serial restart-delay 0
 frame-relay map ip 116.1.156.4 604 broadcast
 frame-relay map ip 116.1.156.5 605 broadcast
!
router ospf 1
 router-id 99.99.6.6
 log-adjacency-changes
 network 116.1.67.6 0.0.0.0 area 67
 network 116.1.156.6 0.0.0.0 area 0

R7
interface Loopback0
 ip address 99.99.7.7 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 116.1.67.7 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 116.1.78.7 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 99.99.7.7
 log-adjacency-changes
 area 67 virtual-link 99.99.6.6
 network 116.1.67.7 0.0.0.0 area 67
 network 116.1.78.7 0.0.0.0 area 78

R8
interface FastEthernet0/0
 ip address 116.1.78.8 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 99.99.8.8
 log-adjacency-changes
 redistribute rip subnets
 network 116.1.78.8 0.0.0.0 area 78

OSPF and Loopback Interfaces

Task: Include all Lo 0s from R5 – R7, ensure that they appear as /24 entries in the routing table.

OSPF uses different network types for different interfaces types, the same goes for loopback interfaces, per default they are set to the loopback (what a wonder) network type. The special thing about a loopback network type is, that OSPF always does advertise its IP address as a host address (/32) no matter what kind of subnet mask we use:

R6#sh ip ospf int lo0
Loopback0 is up, line protocol is up
 Internet Address 99.99.6.6/24, Area 0
 Process ID 1, Router ID 99.99.6.6, Network Type LOOPBACK, Cost: 1
 Loopback interface is treated as a stub Host

R7#sh ip route 99.99.6.6
Routing entry for 99.99.6.6/32
 Known via "ospf 1", distance 110, metric 2, type intra area
 Last update from 116.1.67.6 on FastEthernet0/0, 00:02:20 ago
 Routing Descriptor Blocks:
 * 116.1.67.6, from 99.99.6.6, 00:02:20 ago, via FastEthernet0/0
 Route metric is 2, traffic share count is 1

So to get /24 for the loopback networks, you just have to change the network type to point-to-point. Cisco wont accept any other network type for a loopback Interface:

R6#sh run int lo 0
Building configuration...

Current configuration : 95 bytes
!
interface Loopback0
 ip address 99.99.6.6 255.255.255.0
 ip ospf network point-to-point

R6#sh ip ospf int lo0
Loopback0 is up, line protocol is up
 Internet Address 99.99.6.6/24, Area 0
 Process ID 1, Router ID 99.99.6.6, Network Type POINT_TO_POINT, Cost: 1
 Transmit Delay is 1 sec, State POINT_TO_POINT,
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
 oob-resync timeout 40
 Supports Link-local Signaling (LLS)
 Index 2/2, flood queue length 0
 Next 0x0(0)/0x0(0)
 Last flood scan length is 0, maximum is 0
 Last flood scan time is 0 msec, maximum is 0 msec
 Neighbor Count is 0, Adjacent neighbor count is 0
 Suppress hello for 0 neighbor(s)

R7#sh ip route 99.99.6.6
Routing entry for 99.99.6.0/24
 Known via "ospf 1", distance 110, metric 2, type intra area
 Last update from 116.1.67.6 on FastEthernet0/0, 00:01:55 ago
 Routing Descriptor Blocks:
 * 116.1.67.6, from 99.99.6.6, 00:01:55 ago, via FastEthernet0/0
 Route metric is 2, traffic share count is 1

OSPF verification

A show ip route on R4 shows that it has all OSPF routes in its routing table:

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

 116.0.0.0/24 is subnetted, 4 subnets
O IA    116.1.67.0 [110/65] via 116.1.156.6, 00:20:40, Serial1/0
O IA    116.1.78.0 [110/66] via 116.1.156.6, 00:20:40, Serial1/0
C       116.1.145.0 is directly connected, FastEthernet0/0
C       116.1.156.0 is directly connected, Serial1/0
 99.0.0.0/24 is subnetted, 5 subnets
C       99.99.4.0 is directly connected, Loopback0
O       99.99.5.0 [110/65] via 116.1.156.5, 00:20:40, Serial1/0
O       99.99.6.0 [110/65] via 116.1.156.6, 00:20:40, Serial1/0
O IA    99.99.7.0 [110/66] via 116.1.156.6, 00:20:40, Serial1/0

RIPv2

Tasks: Configure RIP version 2 on R8 and R9, include all Loopback Interfaces on R9 and the Lo0 on R8.

Once again, nothing special here, just don’t forget to use the version 2 and no auto-summary commands.

R8
interface Loopback0
 ip address 99.99.8.8 255.255.255.0
!
interface FastEthernet0/1
 ip address 200.11.99.8 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 99.0.0.0
 network 200.11.99.0
 no auto-summary

R9
interface Loopback0
 ip address 99.99.9.9 255.255.255.0
!
interface Loopback1
 ip address 200.172.5.9 255.255.255.0
!
interface Loopback2
 ip address 200.172.6.9 255.255.255.0
!
interface Loopback3
 ip address 200.172.7.9 255.255.255.0
!
interface Loopback4
 ip address 200.172.8.9 255.255.255.0
!
interface Loopback5
 ip address 200.172.9.9 255.255.255.0
!
interface Loopback6
 ip address 200.172.10.9 255.255.255.0
!
interface FastEthernet0/0
 ip address 200.11.99.9 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 99.0.0.0
 network 200.11.99.0
 network 200.172.5.0
 network 200.172.6.0
 network 200.172.7.0
 network 200.172.8.0
 network 200.172.9.0
 network 200.172.10.0
 no auto-summary

RIP Verification

A show ip route on R9 shows, that it has all RIP routes in its routing table:

R8#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    200.11.99.0/24 is directly connected, FastEthernet0/1
R    200.172.6.0/24 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1
 116.0.0.0/24 is subnetted, 7 subnets
C       116.1.78.0 is directly connected, FastEthernet0/0
R    200.172.7.0/24 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1
 99.0.0.0/24 is subnetted, 9 subnets
C       99.99.8.0 is directly connected, Loopback0
R       99.99.9.0 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1
R    200.172.8.0/24 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1
R    200.172.9.0/24 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1
R    200.172.10.0/24 [120/1] via 200.11.99.9, 00:00:19, FastEthernet0/1

Redistribution

Tasks: Configure mutual redistribution on R8 between RIPv2 and OSPF
Configure mutual redistribution on R4 and R5 between OSPF and EIGRP.
Ensure that R4 and R5 will not relearn routes advertised by R1 from OSPF.

Redistribution between RIP and OSPF

Task: Configure mutual redistribution on R8 between RIPv2 and OSPF

To get a mutual redistribution between RIPv2 and OSPF you’ll have to redistribute the routes from RIP into OSPF and from OSPF into RIP, thats all. The only thing worth to mention is to not forget the subnets keyword within the OSPF redistribution, otherwise OSPF will only redistribute major network addresses. In this case, every network from the 200 range would be redistributed while the loopback addresses from 99.0.0.0 wont.

R8
router ospf 1
 router-id 99.99.8.8
 log-adjacency-changes
 redistribute rip subnets
 network 116.1.78.8 0.0.0.0 area 78
!
router rip
 version 2
 redistribute ospf 1 metric 1
 network 99.0.0.0
 network 200.11.99.0
 no auto-summary

Redistribution between EIGRP and OSPF

Task: Configure mutual redistribution on R4 and R5 between OSPF and EIGRP.

Nothing special to add here, EIGRP asks to specify a default metric for the redistributed networks, which basically is something you can choose what you want but it is a good idea to make the metric as bad as possible, I’ll explain why in the next section. OSPF needs the subnets keyword again and then we got the mutual redistribution between both protocols on R4 and R5

R4
router eigrp 100
 redistribute ospf 1 metric 1 1 1 1 1500
 network 99.99.4.4 0.0.0.0
 network 116.1.145.4 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.4.4
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 116.1.156.4 0.0.0.0 area 0

R5
router eigrp 100
 redistribute ospf 1 metric 1 1 1 1 1500
 network 116.1.145.5 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.5.5
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 99.99.5.5 0.0.0.0 area 0
 network 116.1.156.5 0.0.0.0 area 0

Redistribution and Loops

Task: Ensure that R4 and R5 will not relearn routes advertised by R1 from OSPF.

What is going to happen here heavily depends on how you’ve set the EIGRP Metric for the routes redistributed from OSPF into EIGRP. If the metric for the distributed routes has been set worse enough, there wont be any issue for the reachability, if not the redistributed networks 116.1.2.0/24 and 116.1.3.0/24 wont be reachable on R4 to R9.
The issue here, no matter if the EIGRP metric is set worse enough or not is that either R4 or R5 will relearn those networks over OSPF. Simply due to the reason, that EIGRP external routes have an administrative distance of 170 while OSPF got an administrative distance of 110, no matter if the route is internal or external.
So lets say R4 redistributes those networks from EIGRP into OSPF, R4 then will advertise it through the OSPF domain, including R5. After R5 received the routes from OSPF with an AD of 110 from R4 and with an AD of 170 from R1, it will install the Routes from OSPF due to the better AD.

What is going to happen next now depends on the redistribution metric for EIGRP. If its set too good (better metric then the one from R1), both R1 and R4 will use R5’s advertisement for those routes and not the one to R1. And here we have our little loop no router will be able to ping 116.1.2.2 or 116.1.3.3.

R1#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560002816] via 116.1.145.5, 00:04:50, FastEthernet0/0
D EX    116.1.2.0 [170/2560002816] via 116.1.145.5, 00:04:50, FastEthernet0/0

R4#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560002816] via 116.1.145.5, 00:04:02, FastEthernet0/0
D EX    116.1.2.0 [170/2560002816] via 116.1.145.5, 00:04:02, FastEthernet0/0

R5#sh ip route | i 116.1.2.0|116.1.3.0
O E2    116.1.3.0 [110/20] via 116.1.156.4, 00:03:46, Serial1/0
O E2    116.1.2.0 [110/20] via 116.1.156.4, 00:03:46, Serial1/0

R1#ping 116.1.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 116.1.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R7#ping 116.1.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 116.1.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

There wont be any loop if the redistribution metric for EIGRP has been set worse enough but still either R4 or R5 will relearn the route from OSPF, which is something the task asks to prevent.

R4#sh run | sec router eigrp
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 99.99.4.4 0.0.0.0
 network 116.1.145.4 0.0.0.0
 no auto-summary
<pre>R4#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560514816] via 116.1.145.1, 00:00:19, FastEthernet0/0
D EX    116.1.2.0 [170/2560514816] via 116.1.145.1, 00:00:19, FastEthernet0/0</pre>
R5#sh run | sec router eigrp
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 116.1.145.5 0.0.0.0
 no auto-summary

R5#sh ip route | i 116.1.2.0|116.1.3.0
O E2    116.1.3.0 [110/20] via 116.1.156.4, 00:10:58, Serial1/0
O E2    116.1.2.0 [110/20] via 116.1.156.4, 00:10:58, Serial1/0

R1#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560512256] via 116.1.123.3, 00:16:17, Serial1/0
D EX    116.1.2.0 [170/2560512256] via 116.1.123.2, 00:16:17, Serial1/0

R7#ping 116.1.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 116.1.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/108/128 ms

To solve this problem we got two tools:

  • administrative distance manipulation
  • route tagging

Manipulating the AD is the easier way for this task, since its only 1 command on each router. Route Tagging would imply to tag those routes on their entry point into the EIGRP domain and then again prevent them from reentering on R4 and R5.
One thing to mention here, it is not possible to change the AD for a set of external routes in EIGRP, even though you can configure it, it will not work (why ever, but there are several topics about that on the internet). So changing the AD on the OSPF side to something higher than 170 will do the trick.

R4
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 99.99.4.4 0.0.0.0
 network 116.1.145.4 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.4.4
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 116.1.156.4 0.0.0.0 area 0
 distance 171 0.0.0.0 255.255.255.255 EIGRP-Ext
!
ip access-list standard EIGRP-Ext
 permit 116.1.2.0 0.0.0.255
 permit 116.1.3.0 0.0.0.255

R5
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 116.1.145.5 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.5.5
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 99.99.5.5 0.0.0.0 area 0
 network 116.1.156.5 0.0.0.0 area 0
 distance 171 0.0.0.0 255.255.255.255 EIGRP-Ext
!
ip access-list standard EIGRP-Ext
 permit 116.1.3.0
 permit 116.1.2.0

R4#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560514816] via 116.1.145.1, 00:00:06, FastEthernet0/0
D EX    116.1.2.0 [170/2560514816] via 116.1.145.1, 00:00:07, FastEthernet0/0

R5#sh ip route | i 116.1.2.0|116.1.3.0
D EX    116.1.3.0 [170/2560514816] via 116.1.145.1, 00:00:19, FastEthernet0/0
D EX    116.1.2.0 [170/2560514816] via 116.1.145.1, 00:00:19, FastEthernet0/0

Testing the connectivity

To proof that the configuration works I’ve used the following TCL script and executed it on every router:

foreach LAB {
116.1.145.1
116.1.123.1
99.99.1.1
116.1.2.2
116.1.123.2
99.99.2.2
116.1.3.3
116.1.123.3
99.99.3.3
116.1.145.4
116.1.156.4
99.99.4.4
116.1.145.5
116.1.156.5
99.99.5.5
116.1.67.6
116.1.156.6
99.99.6.6
116.1.67.7
116.1.78.7
99.99.7.7
116.1.78.8
200.11.99.8
99.99.8.8
200.11.99.9
99.99.9.9
200.172.5.9
200.172.6.9
200.172.7.9
200.172.8.9
200.172.9.9
200.172.10.9
} {ping $LAB repeat 3 timeout 1}

Please do not forget to use tclsh before and tclquit after you executed the script.

Full Configuration

Following is every routers “full” (sanitized) configuration.

R1

interface Loopback0
 ip address 99.99.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 116.1.145.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.123.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 serial restart-delay 0
 frame-relay map ip 116.1.123.2 102 broadcast
 frame-relay map ip 116.1.123.3 103 broadcast
!
router eigrp 100
 network 0.0.0.0
 no auto-summary

R2

interface Loopback0
 ip address 99.99.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 116.1.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 116.1.123.1 201 broadcast
 frame-relay map ip 116.1.123.3 201
!
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R2-Connected
 network 99.99.2.2 0.0.0.0
 network 116.1.123.2 0.0.0.0
 no auto-summary
!
ip prefix-list R2-fa0/0 seq 5 permit 116.1.2.0/24
!
route-map R2-Connected permit 10
 match ip address prefix-list R2-fa0/0

R3

interface Loopback0
 ip address 99.99.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 116.1.3.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.123.3 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 116.1.123.1 301 broadcast
 frame-relay map ip 116.1.123.2 301
!
router eigrp 100
 redistribute connected metric 1 1 1 1 1500 route-map R3-Connected
 network 99.99.3.3 0.0.0.0
 network 116.1.123.3 0.0.0.0
 no auto-summary
!
ip prefix-list R3-fa0/0 seq 5 permit 116.1.3.0/24
!
route-map R3-Connected permit 10
 match ip address prefix-list R3-fa0/0

R4

interface Loopback0
 ip address 99.99.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 116.1.145.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.156.4 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 116.1.156.5 406
 frame-relay map ip 116.1.156.6 406 broadcast
!
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 99.99.4.4 0.0.0.0
 network 116.1.145.4 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.4.4
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 116.1.156.4 0.0.0.0 area 0
 distance 171 0.0.0.0 255.255.255.255 EIGRP-Ext
!
ip access-list standard EIGRP-Ext
 permit 116.1.2.0 0.0.0.255
 permit 116.1.3.0 0.0.0.255

R5

interface Loopback0
 ip address 99.99.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 116.1.145.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.156.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 116.1.156.4 506
 frame-relay map ip 116.1.156.6 506 broadcast
!
router eigrp 100
 redistribute ospf 1 metric 1 300000 1 1 1500
 network 116.1.145.5 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 99.99.5.5
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 99.99.5.5 0.0.0.0 area 0
 network 116.1.156.5 0.0.0.0 area 0
 distance 171 0.0.0.0 255.255.255.255 EIGRP-Ext
!
ip access-list standard EIGRP-Ext
 permit 116.1.3.0
 permit 116.1.2.0

R6

interface Loopback0
 ip address 99.99.6.6 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 116.1.67.6 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 116.1.156.6 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 255
 serial restart-delay 0
 frame-relay map ip 116.1.156.4 604 broadcast
 frame-relay map ip 116.1.156.5 605 broadcast
!
router ospf 1
 router-id 99.99.6.6
 log-adjacency-changes
 area 67 virtual-link 99.99.7.7
 network 99.99.6.6 0.0.0.0 area 0
 network 116.1.67.6 0.0.0.0 area 67
 network 116.1.156.6 0.0.0.0 area 0

R7

interface Loopback0
 ip address 99.99.7.7 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 116.1.67.7 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 116.1.78.7 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 99.99.7.7
 log-adjacency-changes
 area 67 virtual-link 99.99.6.6
 network 99.99.7.7 0.0.0.0 area 78
 network 116.1.67.7 0.0.0.0 area 67
 network 116.1.78.7 0.0.0.0 area 78

R8

interface Loopback0
 ip address 99.99.8.8 255.255.255.0
!
interface FastEthernet0/0
 ip address 116.1.78.8 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 200.11.99.8 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 99.99.8.8
 log-adjacency-changes
 redistribute rip subnets
 network 116.1.78.8 0.0.0.0 area 78
!
router rip
 version 2
 redistribute ospf 1 metric 1
 network 99.0.0.0
 network 200.11.99.0
 no auto-summary

R9

interface Loopback0
 ip address 99.99.9.9 255.255.255.0
!
interface Loopback1
 ip address 200.172.5.9 255.255.255.0
!
interface Loopback2
 ip address 200.172.6.9 255.255.255.0
!
interface Loopback3
 ip address 200.172.7.9 255.255.255.0
!
interface Loopback4
 ip address 200.172.8.9 255.255.255.0
!
interface Loopback5
 ip address 200.172.9.9 255.255.255.0
!
interface Loopback6
 ip address 200.172.10.9 255.255.255.0
!
interface FastEthernet0/0
 ip address 200.11.99.9 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 99.0.0.0
 network 200.11.99.0
 network 200.172.5.0
 network 200.172.6.0
 network 200.172.7.0
 network 200.172.8.0
 network 200.172.9.0
 network 200.172.10.0
 no auto-summary
Advertisements

2 comments

  1. Pingback: Solution to Lab Challenge IGP (EIGRP, OSPF and RIP) « Datacomm
  2. thank you

    Generally I don’t learn article on blogs, however I would like to say that this write-up very compelled me to try and do it! Your writing taste has been amazed me. Thank you, quite nice post.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s